vtkSTLReader can't find STL file

How to use openEMS. Discussion on examples, tutorials etc

Moderator: thorsten

Post Reply
_neil_
Posts: 24
Joined: Sun 06 Feb 2022, 23:07

vtkSTLReader can't find STL file

Post by _neil_ » Fri 03 Jun 2022, 19:39

Running openEMS under Windows 10 on Octave 7.1.0 i get an error in the vtkOutputWindow which indicates vtkSTLReader does not find a STL file when i'm using the ImportSTL routine. I'm using the full path file name as input to the routine. In the error box it indicates:
ERROR: In ../../../VTK-8.2.0/Common/ExecutionModel/vtkExecutive.cxx, line 782.

The code works perfectly well under Matlab 2020b on the same Windows machine, and running on a Linux machine from Octave 5.2. So the problem has specifically to do with openEMS running on Octave 7.1.0 running on a Windows 10 machine.

I've tried reinstalling Octave many times on the Windows 10 machine as local and admin user and in difference directories. However, it always get the same error message. After a while the code finishes running generating and output, but from this it's clear the program did not import the STL file.

The code runs fine if i dont use importSTL and use a different input, so the problem has to do with the importSTL routine.

Any clues?

many thanks,
Neil

Post Reply