installation latest github version on Debian Sid

Give some feedback on openEMS.

Moderators: thorsten, sebastian

Post Reply
brutor
Posts: 1
Joined: Sun 20 Feb 2022, 10:24

installation latest github version on Debian Sid

Post by brutor » Sun 20 Feb 2022, 10:42

Hello,
Just a small feedback on the build of the latest github version of Debian Sid.
It all went well, including the hyp2mat and CTB. (the 0.0.35 version in the Debian repository didn't have these)
Attached you have the build_log for reference.

----------------------------------------------------------------------
| openEMS 64bit -- version v0.0.35-76-gd4448fa
| (C) 2010-2018 Thorsten Liebig <thorsten.liebig@gmx.de> GPL license
----------------------------------------------------------------------
Used external libraries:
CSXCAD -- Version: v0.6.2-103-g3c4fb66
hdf5 -- Version: 1.10.7
compiled against: HDF5 library version: 1.10.7
tinyxml -- compiled against: 2.6.2
fparser
boost -- compiled against: 1_74
vtk -- Version: 9.1.0
compiled against: 9.1.0



The hyp2mat tutorial did run well, although there were a lot of warnings

Code: Select all

2022-02-20 09:17:09.281 ( 375.530s) [        40A30EC0]vtkOpenGLPolyDataMapper:313   WARN| vtkOpenGLPolyDataMapper::SetFragmentShaderCode was deprecated for VTK 9.0 and will be removed in a future version.  Use vtkOpenGLShaderProperty::SetFragmentShaderCode instead.
2022-02-20 09:17:13.124 ( 379.373s) [        40A30EC0]QVTKOpenGLStereoWidget.:144   WARN| QVTKOpenGLStereoWidget::GetRenderWindow was deprecated for VTK 9.0 and will be removed in a future version.  Use QVTKOpenGLStereoWidget::renderWindow instead.
Attachments
build_20220219_182217.log
(141.29 KiB) Downloaded 314 times

Post Reply